Перейти к содержанию

Firefox 55 помечает надстройки, не относящиеся к WebExtension, как устаревшие

Начиная с Firefox 57, браузер Firefox не загружает какие-либо устаревшие надстройки. Последняя версия Firefox 55 Nightly начала показывать надстройки, не относящиеся к WebExtension, со значком устаревшей версии в диспетчере надстроек. Таким образом Mozilla предупреждает пользователей о том, что надстройки, которые они используют, не являются WebExtensions. После нажатия на Legacy статья SUMo откроется в новой вкладке, предлагающей подробную информацию о том, что происходит.

«Это начало плана, показывающего пользователям, какие надстройки не подходят для Firefox 57. Речь идет о добавлении флага« устаревшая »в диспетчер надстроек для каждой надстройки, не являющейся WebExtension».

К вашему сведению, начиная с Firefox 53 и далее AMO больше не принимает новые устаревшие надстройки. Mozilla считает, что изменения, происходящие в платформе Firefox, такие как Multi-Process Firefox (e10s), multi-e10s и песочница, могут нарушить работу многих устаревших расширений.

«Еще до Firefox 57 изменения в платформе Firefox нарушат работу многих унаследованных расширений. Эти изменения включают многопроцессорный Firefox (e10s), песочницу и процессы с множеством содержимого. Устаревшие расширения, на которые влияют эти изменения, должны по возможности перейти на WebExtensions. См. Документ «Основные этапы совместимости» для получения дополнительной информации ».

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *