Перейти к содержанию

Исправьте ошибку Chrome: «Это расширение могло быть повреждено вредоносным ПО»

Некоторые пользователи, которые установили расширения, такие как ABP, uBlock, Google Hangouts, HTTPS Everywhere в Chrome (кроме стабильного канала), сообщали на различных форумах, что их расширение было отключено таким образом, что его нельзя снова включить и показать сообщение на странице расширений Chrome: //, вот оно: «Это расширение могло быть повреждено вредоносным ПО» (см. снимок экрана ниже), что может быть ложным срабатыванием и не связано с вредоносным ПО.

Во-первых, это из-за функции проверки контента, которая находится за флагом с названием «Проверка содержимого расширения» и была включена на Canary и на каналах разработчиков, но не на бета-версиях или стабильных каналах. Эта проблема была исправлена ​​Google. Подробнее см. В этой ошибке.

По теме: исправление ошибки Chrome «Попытка перейти на более раннюю версию расширения»

Предупреждение: на всякий случай, вы проверяете эту публикацию, потому что установленные расширения в Chrome 53 или более поздней версии отображаются браузером как поврежденные, затем проверьте это.

Исправьте ошибки, связанные с повреждением расширения Chrome 53, и повторно включите отключенные расширения

Причины проверки содержания, чтобы показать эту ошибку

«Когда мы отключаем расширение в интернет-магазине из-за того, что его содержимое не соответствует ожидаемому хешу, в настоящее время мы отображаем сообщение об ошибке на chrome: // extensions« Это расширение могло быть повреждено вредоносным ПО ». «Участник проекта Chromium, — сказал Асарджент.

Этому также способствуют дисковые ошибки, такие как неполная запись в файл во время обновления / установки, отказ диска или поврежденная файловая система и т. Д.

Затронутые каналы

Похоже, это не касается пользователей стабильной версии Chrome и бета-каналов, в отличие от пользователей Canary и разработчиков. Если вы все еще видите эту ошибку для расширения на странице Chrome: // extensions, то следующие шаги могут вам помочь.

Исправьте ошибку «Google пометил« Интеграцию IDM »как вредоносную, и установка предотвращена»

Исправление сообщения Chrome «Это расширение могло быть повреждено вредоносным ПО»

1 Удаление и повторная установка уязвимого расширения устранила проблему для некоторых. Это может быть случай, когда вы используете старую версию расширения, но разработчик уже обновил расширение в Интернет-магазине, исправив эту проблему.

2. Сбросьте флаги Chrome по умолчанию, перезапустите браузер. Если вы играли с настройками флага chrome: // flags / # extension-content-verify, установив «Enforce Strict», изменение его на «Bootstrap» сработало для некоторых. Пойдите и сбросьте все флаги по умолчанию, это вам не повредит.

Вы видите эту ошибку для любого установленного расширения в Chrome? Дай мне знать в комментариях.

Добавить комментарий

Ваш адрес email не будет опубликован.